고객센터

호스트메카의 새로운 소식과 서비스 이용에 관련된 정보를 제공해 드립니다.
고객센터 · 공지사항
제목 [보안패치] OpenSSL 다중 취약점 보안업데이트 권고
등록일 2014.06.09

안녕하십니까? 호스트메카 서버 관리팀 입니다.

최근 OpenSSL 다중 취약점이 발견됨에 따라 보안조치 당부드립니다.
 

개요
  - 취약한 OpenSSL 버전을 사용하는 서버와 클라이언트 사이에서 공격자가 암호화된 데이터를

    복호화할 수 있는 취약점, 서비스 거부 취약점, 임의코드 실행 취약점 등 6개의 취약점을

    보완한 보안업데이트를 발표함

 

설명
  - 조작된 핸드셰이크 전송을 통한 중간자(MITM) 공격으로 전송데이터를 복호화하고

    서버/클라이언트 간 전송 데이터의 조작이 가능한 취약점 (CVE-2014-0224)
  - 비정상적인 DTLS 핸드셰이크를 OpenSSL DTLS 클라이언트에 전송하여

    서비스 거부 공격이 가능한 취약점 (CVE-2014-0221)
  - 비정상적인 DTLS 프래그먼트를 OpenSSL DTLS 클라이언트 또는 서버에 전송하여

    임의코드 실행이 가능한 취약점 (CVE-2014-0195)
  - do_ssl3_write 함수의 결함으로 인해 임의코드 실행이 가능한 취약점 (CVE-2014-0198)
    ㆍ 해당 취약점은 OpenSSL 1.0.0과 1.0.1에서 SSL_MODE_RELEASE_BUFFERS 옵션이

       활성화되었을 때 발생(해당 옵션은 기본적으로 비활성 상태임)
  - ssl3_read_bytes 함수의 경쟁 상태(race condition)으로 인해 공격자가 세션에 데이터를 주입시키거나

    서비스 거부 공격이 가능한 취약점 (CVE-2010-5298)
    ㆍ 해당 취약점은 OpenSSL 1.0.0과 1.0.1을 사용하는 멀티쓰레드 어플리케이션에서

       SSL_MODE_RELEASE_BUFFERS 옵션이 활성화되었을 때 발생

       (해당 옵션은 기본적으로 비활성 상태임)
  - anonymous ECDH ciphersuites가 활성화된 OpenSSL TLS 클라이언트에

    서비스 거부 공격이 발생할 수 있는 취약점(CVE-2014-3470)

 

해당 시스템
  - 영향 받는 제품 및 버전
    [1] OpenSSL 0.9.8 대 버전
    [2] OpenSSL 1.0.0 대 버전
    [3] OpenSSL 1.0.1 대 버전

 

해결 방안
  - 해당 취약점에 영향 받는 버전의 사용자는 아래 버전으로 업데이트
    [1] OpenSSL 0.9.8 대 버전 사용자 : 0.9.8za 버전으로 업데이트
    [2] OpenSSL 1.0.0 대 버전 사용자 : 1.0.0m 버전으로 업데이트

    [3] OpenSSL 1.0.1 대 버전 사용자 : 1.0.1h 버전으로 업데이트

 

[참고사이트]
  - http://www.openssl.org/news/secadv_20140605.txt